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Chapter 1. Getting Started With DesignSpark 

Introduction to DesignSpark 
Welcome to the DesignSpark PCB design system. The system is built on an integrated design 
environment providing all the tools required to capture a schematic through to the design and layout 
of the printed circuit board (PCB).  

Introduction to the Tutorial 
You can quickly familiarize yourself with the DesignSpark features available and its design 
methodology by working your way through this tutorial and using the Online Help for more detail. 

This tutorial is broken down into logical sections following a typical Schematic and PCB design cycle.  

The Schematic design editor is used to capture your logical design and ‘drive’ the PCB design. 
However, the PCB design editor can be used with or without the schematic design as you wish.  

An important aspect of the PCB design is the production of professional manufacturing data, and 
hence the final PCB. DesignSpark has the facility to send the manufacturing data directly to your 
PCB supplier. From this data they can produce the final physical PCBs. 

Additional Help 
Help is available in a number of formats; on-line help available by pressing the <F1> key on your 
keyboard at any time when using DesignSpark or by emailing/calling RS Components. 

System Requirements 
DesignSpark runs under the Windows operating systems but it is recommended that Windows XP is 
used. It cannot run under Windows 3.1x or Linux. A Pentium processor faster than 1Ghz and with at 
least 256Mb of RAM is recommended. It should be emphasized that DesignSpark does not require 
particularly ‘high-powered’ hardware to achieve good performance, a regular off-the-shelf PC should 
be sufficient. A complete product installation requires at least 100Mb of hard drive space. A mouse 
with a wheel is recommended and an internet connection for downloading the product from the 
DesignSpark web site. A CD-ROM drive is an option to load the product CD if it has been supplied 
this way. 

Installation 
It is assumed that you have successfully installed the DesignSpark product to your computer from 
the web download. The installation is straight forward using the wizard provided. Follow the 
instructions and use the default settings provided. The tutorial designs are also installed to allow you 
to pick up at key stages of the design process. 

Removing the Software 
If for any reason you need to remove DesignSpark from your computer, you should do this by 
selecting the Add/Remove Programs icon from the Control Panel on the Start menu. Select 
DesignSpark from the list of installed programs and click the Change/Remove button. 

Starting DesignSpark 
During installation, a DesignSpark program icon is automatically added 
to your desktop and a RS Components program group added to the 
Start menu and Programs. 

To start DesignSpark, simply double-click on the DesignSpark icon on 
your desktop or select the DesignSpark menu item.  
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The DesignSpark Desktop 
When you run DesignSpark, the main application window appears. You can open any number and 
combination of different designs and library items together in this. 

The picture below shows you the major framework facets by name so that as they are used in this 
tutorial you will understand what is being talked about. 
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Toolbars 
DesignSpark is installed with a set of commonly used tools on the toolbars for you to use. 

General Toolbar 

 

Schematic Design Toolbar 

 

 

 

 

If you hover the mouse over the toolbar 
buttons a small tooltip is displayed showing the 
button function and its keyboard shortcut if one 
has been defined. 

PCB Design Toolbar 
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Cancelling Commands 
All dialogs and commands can be cancelled at any time by clicking the <ESC> key on the keyboard. 
Sometimes this will need to be clicked a couple of times if you are ‘down’ in a sub-menu or lower-
level option. 

Shortcut Keys 
As well as the toolbars, DesignSpark has the ability for you to program your keyboard for commonly 
used options or commands. This means that once programmed, you can press a key or key 
combination to enter a function or option. For experienced users, this makes the program's 
operation far more efficient. 

When DesignSpark is installed, you will find a set of shortcuts defined for you. A full report of all the 
assigned keys can be obtained from the Help menu and Shortcut Keys… option. A dialog is 
displayed to allow you to choose how the shortcut keys are reported. 

 

Units 
The Units option on the Settings menu is used to define the units and the precision at which the 
co-ordinates and lengths displayed in the dialogs and edited by you are displayed. The basic working 
units can be changed using the Units: drop down list.  

 

For each type of units, you can specify a 
Precision:. This is the number of decimal 
places displayed; the value is simply 
rounded to the nearest last digit. 

 

Grids 
Grids are used in DesignSpark for defining the points or steps that items will snap to when they are 
placed and for visible references in the design. For this, the Grids dialog on the Settings menu 
contains two sets of grid types: Working Grid and Screen Grid.  

 

The Working Grid page will allow you to define the 
grid used for placement of design items during 
manual interaction. The working grid is not visible 
but the Screen Grid (which is visible) can be the 
same value, hence making it appear to be visible.  

 

 

 

The Screen Grid page is used to define the display 
of 'dots' to guide you while designing. Size Steps: 
is used to define the ‘pitch’ of the grid and uses the 
Secondary Color to display them. The Primary 
Color is used to display another grid based on a 10 
times larger size than the Secondary Grid. 

The Visible check box enables the grids to be 
displayed on or off, this can be set at any time in 
the design using the shortcut key <G>. 
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Snapping to Grid 

The Snap Mode shortcut can be displayed during editing by selecting the direct keyboard command 
<Ctrl-G>. By selecting the snap mode setting you can use predefined multiples of the Working Grid 
to move items for example. 

 

Shortcut Menus 
The right hand mouse button can be used extensively throughout DesignSpark to display shortcut 
menus, these are also known as context menus. These menus can be accessed during an 
operation and contain a set of relevant 'context' commands. 

Once familiar with the system, you can access the shortcut menus by right clicking directly on the 
item and picking the option from the menu. 

 

Undo/Redo 
DesignSpark contains unlimited multi-level Undo and Redo capabilities for use through the product. 
Undo can be used to reverse the last operations that have been completed. Undo can be used 
sequentially to undo more than one operation. It can also be a useful and flexible tool to 
interactively try different iterations of an operation, manual component placement for example.  

Undo and Redo are invoked using the standard Windows shortcut keys <Ctrl-Z> (and Alt-
Backspace) and <Ctrl-Y> respectively. These are also available on the Edit toolbar as buttons. Redo 
is only available once an Undo has been performed, until then, it remains on the menu but is grayed 
out as unavailable. The number of undo levels can be set in the Preferences dialog. 
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Properties of items 
Each item in the design contains a set of characteristics which can be viewed or edited using the 
Properties option. Some items within the design are made up of several entities, each of which is 
individually selectable and has its own properties that can be viewed. 

 

Item properties can be viewed by 
selecting the item and clicking on the 
Properties option from the shortcut 
menu. It is quicker though to select the 
item and click the shortcut key  
<Alt-Enter>. The example left shows the 
Component page properties of a PCB 
Component pad. You’ll notice that other 
properties of the component are 
available, such as Component and 
Component Values. 

 

Status Bar 
The status bar at the bottom of the design window displays useful information about the design item 
selected. More detailed information is also available by selecting the item and using the Properties 
dialog from the shortcut menu. 

 

Dockable Windows and Browsers 
As part of the design toolset, you have a number of browsers available through the Interaction 
Bar.  

 

The Interaction Bar is available through 
the View menu and Interaction Bar 
<F9> or by right clicking the mouse over 
one of the toolbars or menu bar and 
selecting it from the shortcut menu.  
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Each individual browser can be opened by 
selecting one of the three tabs at the bottom edge 
of the browser. You can access Layers (in PCB 
only), Component Bin (in Schematics only), 
Goto and Add Component options. 
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Chapter 2. Creating The Schematic 

Schematic Design Tutorial 
During the tutorial we will create a Schematic design; this is how it will look when finished.   

 

During the design process, we will walk you through all the aspects of drawing this and adding the 
detail to give it intelligence. 

The design consists of two parts; the first is the power regulator circuit at the top which converts a 
12V supply to 5V. The bottom half is the main 555 timer circuit itself. 

Starting a New Schematic 

 To start a new Schematic design or a PCB design 

From the File menu, click New (shortcut key <Ctrl-N>) 

 

Check the Schematic Design button and the Use Technology File button. The Default.stf 
template will help you get started quicker, select this file. More detail about Technology files is 
available in the Online Help. 
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Click the OK button to start a new Schematic design. 

Note: If you intend creating a PCB without a Schematic design (which you can do), just click the 
PCB Design button and OK, follow the New PCB Wizard. Then skip to the chapter headed, Starting 
a New PCB Design. 

Your DesignSpark window will look like this ready to start: 

 

For now, we will progress on to adding components to the design. 

Adding Components 

 To add a Component 

There are two methods for adding components; we will use the Interaction bar to start with, you 
can also use the Add Component option as well. 

The Interaction bar has automatically been started when creating a new Schematic design. If it 
hasn’t, click the <F9> shortcut key to display it.  

Select the Add Component browser tab at the bottom of the Interaction bar. 
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From the list of available libraries, select the Discrete library. Click on the small down arrow to 
reveal the drop down list and then make the selection. 

 

The Component list will be populated with components. Selecting this library will automatically 
select the first component in the list as well. 
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Scroll down the list of components using the vertical scroll bar. The first in the list is the generic ‘C’ 
component. You can also click in this list and type the first and subsequent letters and numbers of 
the item required. 

Scroll down and select the component R. This is a generic resistor that we will change the Value for 
later on. You can also work with specific named parts if you prefer, both methods are acceptable in 
DesignSpark. 

 

A preview of both the Schematic and PCB symbols will be displayed (the PCB symbol is top most in 
the preview). 

Once you have the correct component, you can add it by selecting the symbol preview and dragging 
it into the design. You can also add the component by selecting and dragging its name. 

 

This is a one-shot process. If you wish to add more of the same type, drag another from the bin. 

The component is currently on the end of your cursor. To place it in the design, click the left mouse 
button once. 
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You need 7 resistors in total for the final circuit. Once the first one has been placed, pick and drag 6 
more from the Add Component window. Position them in a stack like the picture below. For now, 
their position isn’t important anyway. 

 

 To pan & zoom in the design 

To view the resistors closer, roll the mouse wheel button forward to zoom in. If you zoom in too fast 
(and too far), roll the mouse wheel button backwards (slowly). If you zoom too far either way, press 
<A> on the keyboard to View All and then zoom in or out again. Shortcut keys are also available 
for Zoom in <Z> and Zoom out <U>. 

You can zoom while the component is active on the end of your cursor. 

 

Zoom out to give yourself space around the resistors in which to place more components. 

 To add the capacitors 

We need 7 normal capacitors for this circuit plus 4 electrolytic capacitors. From the Add 
Component browser option again type C in the component list. The component name will jump 
back to the C component in the list. 
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The preview windows confirm this is the correct component. As with the resistors, this is a generic 
component and we will change its value later on. 

As before, dragging a component from the browser will add another to the design. This time only 
drag out one capacitor to add C1 and then pause. The design will look like this: 

 

We will use a different technique to add more capacitors. 

Select the capacitor C1 in the design. Press the <Ctrl-C> keys on your keyboard at the same time 
to Copy the capacitor. Now press <Ctrl-V> to Paste a copy of the capacitor into the design. You will 
see that an identical copy of C1 has been made and is named C2. These are standard Windows 
commands. 

 

Move C2 into position and just underneath C1 by moving the mouse. Single click to release. Now 
use <Ctrl-V> again, to add another capacitor C3 and then again to add C7.  

Your design now looks like this: 

 

Obviously in a design as simple as this, it would have been quicker to drag out all 7 capacitors but 
the Copy/Paste principle is worth demonstrating as you will see its value later one. 
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 To switch off the displayed grid 

At this stage we don’t really need to see the displayed grid dots so let’s switch them off. Click <G> 
to toggle the grid off. Press this key again will switch it back on at any time. 

 To add the Op-Amp 

Our design requires an 555 Timer and a TL072. We will use another technique to add these 
components. There will be other components to add also but we can add these later as you would in 
a real design; building the design up as you progress. 

Click the Add Component button on the toolbar, shortcut key <F3>. 

 

The Add Component dialog will display [All Libraries] in the library path. We will us the Find option 
to locate both of these components in the library. 

 To Find components in the library 

From the Add Component dialog, click the Find button. 

 

We will find the NE555 timer first. For the Name selection, choose Contains from the drop down 
list. In the text entry, type ne555. This will be enough to get near a name to then match what we 
need. 

 

Click the Find button. The contents list will be populated with all matching items from all the 
libraries. 
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Select NE555P at the bottom of the list from the Hybrid library.  

You can either send this component to the design by using a double-click or you can preview it in 
the Add component dialog contents list by selecting the Close button. We will use the Add 
Component method on the first device and the double-click method on the second. 

After selecting, you’ll notice that this component is now preselected in the Add Component dialog 
behind this. 

 

Use the Close button on the Find dialog. 

 To add components 

With the NE555P selected from the Hybrid library, press the Add button and add it to the design. 

Depending on your current zoom level, you may need to roll the mouse wheel to zoom out a little. 
You will need to give yourself some space on the design in which to place this new component. 

The NE555 (U1) is shown in the design on the end of your cursor. Position it next to the capacitors 
but it doesn’t matter where it goes for now. 

Go back to the Add Component dialog <F8> and click the Find button again. 

Type in tl072 – note the case typed isn’t important. 
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Click the Find button. 

 

This time, double-click on the name in the found list. Both the Find dialog and Add Component 
dialog will close and the component will be on the end of your cursor ready to place in the design. 

This is a two-gated device. Click the mouse once to place the first gate. The second gate will now be 
dynamic on the end of your cursor ready for placing. We do not need this gate so it can be discarded 
(into the Component Bin off the design sheet).  

Click the <Esc> button to discard it. 

The design now looks like this: 

 

Before we make the connections we should change the component values to be the ones required. 
This is easy to do because we’ve used ‘generic’ components. If you prefer to use specific Part named 
components (a unique Component for each device you order and buy in), you can also work this 
way with DesignSpark. 

All the resistors and capacitors we have used in this example circuit are generic. They all have the 
same values at the moment. In the next exercise, we will change their values to be unique and as 
required. 

 To edit component Values 

Double-click on the Value field (1K) on R1, the Component tab of the Properties dialog is 
displayed.  
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We need to use the Values table to change the values so click on the (Component) Values tab. 

The Value field shows the current 1K value and is already highlighted. Simply click the Edit button 
or double-click the blue highlighted field to edit the value required.  

 

Type in 100K. 

When done, click the OK button to exit this dialog and OK again to exit Properties dialog. When 
the value of R1 is changed to 100K the design is updated. 

Using the same process (double-clicking on the Value name), edit the Value fields for all R’s and C’s 
in the design as shown below: 

 R1 100K R2 100K R3 2K R4 100K R5 2K R6 1K R7 787K 

 C1 100nF C2 100nF C3 100nF C4 100nF C5 100nF C6 220nF C7 10nF 

A quick tip here is that if there are a couple of components with the same value, edit the first one 
then copy it as many times as you need rather than editing each one. 

Our design now looks like this: 

 

If you select the whole component by mistake, you can still edit the Value field by clicking the 
Component Values tab on the Properties dialog. 

You can also use the Values option on the shortcut menu instead of Properties. This just takes you 
directly to the Values page of Properties to save time. 

 To add a drawing border to the design 

At any time you can add a drawing border to the design. We will add one now. 

Using the Add Component Browser again (<F9>), select the Schema library from the drop down 
list. For reference, this is a schematic only component library and will not have any PCB symbols 
associated with them. 

Scroll down the list and select the A4 drawing border. This has been previously created to fit an A4 
page size. 
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Note there is no PCB footprint for this component, it is Schematics only. 

Like other components, select A4 from the list or from the preview. Drag it into the design and 
position it on top of the existing components. You may need to zoom out a bit to see it all to place it 
somewhere near. Use the <Z> key to zoom out or <A> to view all of the design. For speed you can 
also roll the mouse wheel. 

 

As with other components, this can be moved and edited later if you need to, extra detail can be 
added to it. Click once to release it. 

 To save the design 

At this stage it might be a good idea to save your design. Go to the File menu and select Save As. 
Save it to the Examples folder and call it something sensible, like Tutorial.sch. 
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Placing Components 
The position of the components currently is as they were placed after adding them to the design. We 
need to place them around U1 so they can be used in our circuit. On a real design, this would be 
how you would work in practice. To remind you, the full circuit looks like this: 

 

Move the components into position by picking and dragging them in one move using the mouse. 
This methodology is used throughout to save time and effort. It means, a continuous select and 
drag of the mouse without releasing on a component (or other items, this works for moving any 
item). When you release the mouse, the component placed and deselected in its current position. If 
you make a mistake, use Undo <Ctrl-Z> to restore its position. 

Components can be rotated during move by clicking the <R> key. A single click of the <R> key will 
rotate the component by 90 degrees. Click <R> more than once to rotate it by another 90 degrees 
and so on. There are other rotate modes and rotation increments available on the shortcut menu 
when moving the component. 

Note: You can also change the placement to fine tune it after adding the connections as well. 

The design will now look like this (with part of the circuit placed): 
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Place the other components. The order in which you place them doesn’t make any difference. In a 
real design, you would add and place them logically as you build up the circuit. 

 

Two capacitors are left unplaced (C6 and C7), these will be placed at the a later time when we 
create the voltage regulator. 

You are now ready to add some connections. 

Adding Connections 
Connections are added to the Schematic design to make connectivity between electrical pins. When 
translated to the PCB design, these connections give you your net list. 

You can add connections in a number of ways: 

 Using the Add Connection option from the Add menu or from the Schematic Toolbar, 
click on the pin to start adding a connection, or; 

 Double-clicking on a component pin to start a new connection, or; 

 'Dragging' off an unconnected component pin to start a new connection. 

For this tutorial we will use the ‘dragging off pins’ method as this is the easiest to start with. 

 To add connections by dragging off pins 

To aid the addition of connections to a schematic, you can simply ‘drag’ off an electrical pin, each 
click of the mouse will then add a corner. Moving over another electrical pin will allow you to finish 
the connection. 

Using the design that you have created so far, zoom in on the area around C5 like the picture below. 

 

Click and drag (keeping the mouse button pressed down) off pin 2 of C5, this will start a new 
connection. Move the mouse over U2a pin 3 and single click to finish. 

 

You do not have to be exactly over a pin to finish a connection; as long as the cursor is within range 
then it will snap onto the terminal. Click the mouse button once to finish. You’ll notice that the 
component pin terminals X disappear when you connect to it; this indicates that it is connected. 
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 To join connections together 

There are a couple of connections which must be connected together. Let’s assume that you’ve 
made a connection and now you need to connect another to it using a junction dot. When you 
attempt to finish a connection on an existing connection, when you release the mouse, the 
connection will automatically be added (as if it were an electrical terminal) and a junction dot 
displayed to indicate it is connected. 

 

Following the example design above, complete the design adding the connections required. 

Adding Power & Ground Symbols 
Power and ground symbols are used in the Schematic to indicate a connection to a power source. 
These symbols are required for aesthetic purposes and are not translated to the PCB (because they 
do not have PCB footprints associated with them). The signals they represent are connected 
together at the translate stage by ‘implied’ connectivity. The power & ground symbols themselves 
can contain inherent net name properties that are automatically used when the symbol is attached 
to the net. 

 

 To add Power symbols 

Using the Add Component browser on the Interaction bar <F9>. 

 

The Schema library will still be selected after using it previously 
when adding the Letter component. If for some reason it isn’t, 
select it now from the library list. 

In the Component list select 0V. You will see the symbol 
selected in the preview box. Remember, all of these symbols 
have no PCB Symbol associated with them, they are Schematic 
only symbols. 
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Drag the 0V symbol into the design from the browser. Move it between R3 and R6, click the mouse 
to release it. 

 

Using our working design, add more 0V symbols to the design as shown. Connect these by dragging 
off the symbol to the existing connection. A confirmation dialog will be displayed to indicate a non-
named net is being connected to a named net. This ensure you aren’t joining nets which you don’t 
know about. 

 

Click OK to confirm this. 

From the Add Component browser, add one +5V symbol this time and place near R4 and C4. Now 
add one -5V symbol, place it near C3. 

Drag a connection off the end of the symbol terminal and connect as shown below. 

Your design will look something like this: 

 

Remember to save the design. Use Save from the File menu. 

You will need to add a diode to the design. 

From the Interaction bar <F9>, use Add Component. Select the Discrete.cml library and choose 
D from the list. This will give you a generic diode. 

If you prefer, and now that you know how to do a Find in the Add Component dialog, search for a 
specific diode. You actually need a 1N4148, but if you choose the generic dialog from the library, 
edit the value so that you make it a 1N4148. 
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Add the diode by dragging it from the browser into the design. Place it 
next to R2 and rotate it by 270 degrees (click <R> 3x times. 

 

Add two connections to connect it to both sides of R2 as shown. 

 

Generally speaking you would now need to add some connector pins to connect the circuit to the 
outside world. 

Adding Connectors 
For this example, we will use a connector component from the library. Connectors are simply 
additional library items and not special devices as such. 

 To add Connector pins  

Using the Add Component browser from the Interaction bar <F9>. Select the Connector.cml 
component library. 

Select the D9F connector component from the list. The PCB Symbol and Schematic Symbol previews 
will be displayed. 

Drag it into the design and place it shown below. You will need to Flip it by using the <F> key. This 
will display it the way we need it. 

 

Connect in the connector to the design using Add Connection or by dragging off a pin.  

 Add more components  

You will also need to add four more capacitors, but this time, add the Component CP using the Add 
Component browser or dialog and use the Discrete.cml library. Add C8, C9, C10 and C11. We 
will use C8 and C9 a bit later on. 

Place C10 and C11 near the connector CONN1. Connect these as shown below: 
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Click the Save button on the File menu to save the design. 

Using the picture below, complete the circuit by adding the voltage regulator circuit. 

 

We already added the capacitors C6, C7, C10 and C11 but you will now need to add U3 which is a 
7805. 

Change the component values for the remaining capacitors to these values: 

 C8 47uF C9 470uF C10 100uF C11 100uF 

Add Signal references for +12V, +5V and 0V from the Schema.cml library as you did before. If 
the symbol already exists in the design, simply copy and paste it for fast addition. 

The input side of U3 on pin 1 is +12V. This will be connected to pin 1 of Conn1, the connector. 

Adding Net References 
As an exercise, we’ve added a Net Reference to the design. This is two pins on opposite sides of the 
design perhaps which need to be connected together but for which you do not need to add a full 
connection. 

We will add a short connection for each pin, add a schematic only component as the signal reference 
and name the net on both ends. This will act as an ‘implied’ connection. Then when the Schematic is 
translated to PCB, these two points will be connected together. 
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From the Add Component browser, from the Schema.cml library, add two To components to the 
design. 

Add a connection between CONN1 pin 8 and the To symbol. 

Remember, the intelligence in the implied net is the net name, so now we must name the 
connection. 

 Using Change Net 

Select the pin on the To symbol. From the shortcut menu, select Change Net. 

From the dialog, type the Net Name: SINE_OUT 

Leave the Net Class as Signal. Click OK to exit. 

 

The Net is now named (SINE_OUT), now you need to display it. 

 Displaying Net Names  

Select the pin on the To symbol again. 

Right click and from the shortcut menu, select Display Net Name. 

Now that it is displayed, you can select it and move it into the required position. 

 

That is one half of the implied net completed. You must now do this procedure again for the other 
pin. 

 Making the other half of the implied net 

We will move the second To symbol to the right side of U2 (the TL072 component). 

Add a small connection between the output pin 7 of U2 and the To symbol. 

Now using the same technique as we used just above, change the Net Name to 
SINE_OUT and display it using the Display Net Name option from the shortcut menu. 
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Your Schematic is Finished 
The schematic design is complete, remember to save it now. You may wish to print it to check it, 
use the Print option from the File menu. 

 

The next stage is to convert the design into the PCB design environment. To do this, move onto the 
next chapter Converting Your Schematic To PCB 
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Chapter 3. Converting Your Schematic To PCB 

Overview 
There are three methods for creating new PCB designs: 

1. From a Schematic using DesignSpark as the capture ‘front-end’ to the PCB system. You will use 
the Translate To PCB option to take the netlist into the PCB editor. Nets and components used 
in the Schematic are converted to PCB in the integrated environment. 

2. Use the DesignSpark PCB design editor interactively creating the design on-the-fly without the 
need for an initial netlist. You just add components and connections as required to create the 
PCB design. 

3. From an external netlist and import it through the import mechanism to create a new PCB 
design. 

Converting the Schematic to PCB 
If you created a Schematic in DesignSpark, the final process before starting on the PCB design 
itself is to translate the Schematic design into the PCB design editor.  

When you are in a position where you wish to go-ahead with this translation you should select 
Translate To PCB from the Tools menu and use the Translate To PCB option. 

 

This will display the New PCB wizard. Whether you create a PCB design by using the Translate To 
PCB option or by using the New option and PCB Design, you will be presented with the New PCB 
Design Wizard. 
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The New PCB Wizard 
This wizard presents you with a set of dialogs which step you through a sequence to define aspects 
of your design in the PCB design editor. The online help is available for each page by pressing the 
<F1> key at any time. 

Click Next > to move onto the next page. You can also click the page name you require in the list at 
the top left hand side of the page but is recommended to work through the wizard pages in 
sequence. 

On the Start page select the check box to agree with the disclaimer. You must click this to proceed 
further. It is only shown once after you have selected it for the first time. Click Next> to proceed. 

The Technology page allows you to predefine a Technology file and your design Units. Technology 
files allow you to create a set of sizes (styles) and design spacing rules that can be used time and 
time again on different designs. This enables you to be consistent with naming conventions and 
standards. It also provides you with a fast way to get your designs started. 

The Units are defined here to get you started, as are the unit Precision, but both can be changed 
at any time during the design process. 

For our example, select Choose Technology File: (we want to use an existing one), and select 
2sig2plane.ptf from the drop down list. 

For Units: select thou and 0 precision. If you prefer Metric units, choose mm and 3 as the 
precision. 

 

Click Next > to proceed. 

The Layers page allows you to change the layer usage from that of the Technology file if you 
specified one. For our example, we will leave the selection as Use Layers From Chosen 
Technology File. The layers selection will display the contents of the Technology File but you 
cannot edit them, only view them. These can be changed once in the PCB design anyway, this dialog 
gives you visibility of the selection and the ability to make changes up-front. 
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If you decided to make changes to the Layers, the Define Layers button should be selected. Use 
this once you understand the implications of making changes to layers. 

 

Leave the selection as Use Layers From Chosen Technology File. 

Click Next > to proceed. 

You should now define the shape and size of the board outline using the Board page. You can 
define your board as a rectangle/square, or a circle and it’s Width/Height or diameter in the 
current units. 

If your chosen Technology file contains a board outline (which it can), you can elect to use this. 

You can also choose to Copy Board Outline From Another File (another PCB design file or 
different Technology file). If using a PCB design for the board outline, the PCB file must reside in the 
Technology file folder. 

For our example, choose Define Board Size and set the Width and Height to 3000 each. 

 

Click Next > to proceed. 
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The Place And Route page allows you to automatically let DesignSpark place components and then 
route their connections using the autorouter. 

 

Under Component Placement, you can elect to place components in an Arrangement Outside 
the Board to stack them by type outside the board outline. This makes them easier to see and 
place manually. 

 

Use Automatically Position Inside the Board to place the components on the board. It will 
attempt to work out the best way to arrange the components on the board to keep the total length 
of tracks as small as possible, without packing them too tightly together. The two controls will 
enable you to define how components are placed using your preference and possibly, your assembly 
or manufacturing processes. 

 

For our example, change the Minimum Gap Between Components and Component Grid values 
to 100 (thou) each. We will allow plenty of space between the components. If you decide you’d like 
less space between each component, you can run the Auto Place Components> option from the 
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Tools menu once in the PCB editor, you don’t need to go back through the New PCB Wizard. Before 
the design is routed, this can be an iterative process of trial and error. 

Don’t forget also, even though the Auto Place option has made your placement for you, you can 
manually place components at any time to refine the placement by picking and dragging them 
(more of this later on). 

Check the Automatically Add Tracks Between Components box to let the router convert the 
schematic netlist into PCB tracks. This is only available if you have chosen to Autoplace the 
components in the section above. Leave unchecked if you intend routing the board by hand, or need 
to alter the design before letting the autorouter finish it. You can run this option once in the PCB 
Design using the Auto Route Nets> option from the Tools menu. 

For our example, check this box to let the autorouter route the design for you (you can unroute it if 
you decide to have a go with the manual routing options). 

Click Next > to proceed. 

Use the Finish page to set your PCB Design Name and to Save it to a file. By default, the PCB 
design name will be the same as the Schematic design name. It doesn’t have to be but it makes 
sense to keep them the same, especially when running options such as Forward Design Changes 
which will look for the opposite design type of the same name. 

 

At any time (and before you hit the Finish button) you can go back to one of the previous pages by 
selecting the page name form the list displayed. 

 

When you click the Finish button, the PCB design editor will run up and your PCB design will be 
ready for use. Your design background will be black, we’ve changed the colours for the picture so it 
is easier to view in the PDF file. 
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Starting a New PCB Design without a Schematic 
If you intend starting a new PCB design without using a Schematic design first (which you are quite 
able to do), from the File menu select New and check the PCB Design radio button. 

 

Click the OK button and this will start the New PCB Wizard. This will run you through the wizard as 
described above. 

Schematic Design Completed 
You have now completed the first section of this introductory tutorial so let’s move on. Leave 
everything as it is and read on if you wish to continue with the PCB design tutorial. 
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Chapter 4. PCB Design Editor 

Converting the Schematic to PCB 
If you are following the tutorial, you would have already processed your ‘logical’ Schematic design 
into the ‘physical’ PCB design layout editor using the Translate To PCB option and PCB Wizard. If 
you didn’t do this, go back to the previous chapter (Converting your Schematic to PCB) and convert 
your schematic into a PCB design ready to carry on with this tutorial. 

 

At this point you would normally be ready to start laying out the PCB design. For our example, we 
created the board outline, placed the components and routed the connections. This enabled you to 
see the full process working. 

 

The board outline is displayed with the components placed (and routed), we are going to undo this 
and do it all manually. 

Unroute the Design 
You may sometimes have a requirement to unroute all or part of the design, as we do now. 
Unrouting is the process of removing tracks leaving only the connections remaining. 

 Unroute the design 

Select the Unroute Nets> All Nets option on the Tools menu to unroute the whole design 
removing all the tracks already routed. Three Unroute options available to control the amount of 
unrouting to perform – All Nets, Browse and Selected Nets. 

Don’t forget, once unrouted, you can always restore the routes using Undo <Ctrl-Z>. 
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Changing the Number of Layers 
If you decide at any time to change the number of physical layers or the type of manufacturing, you 
can do this using the Settings menu and the Design Technology option, choose the Layers tab. 

 

Be aware that reducing the number of layers using Delete could lead to information on the inner 
electrical layers being lost. 

Creating a Board Outline Interactively 
If you require a custom board size and shape, and decide not you use our pre-defined shapes of 
rectangle or circle, this can also be easily achieved. 

Deleting an existing board outline 

DesignSpark only requires one board outline so you would need to delete any previous one first. You 
can edit an existing board outline as well. If you do need to delete it, simply select the outline and 
click the Delete button on your keyboard. 

Adding a new board outline 

Board outlines can be created easily in DesignSpark; by adding board shapes (including circles). The 
Add Board option on the Add menu allows you to interactively create a board outline by drawing it 
into the design. Four shape styles are provided: Rectangle, Shape, Circle and Square. There is 
also a shortcut on the PCB Design toolbar to add a Board Polygon. 

Board outlines are created as a Closed shape so during addition, you’ll see the ‘trailing’ board 
segment trail back to the start point. Click to add corners. After adding the last corner, use double-
click to finish. If during the insert, you wish to cancel, click the <Esc> key on the keyboard. This 
will create you a board outline as a continuous shape starting and finishing at the start point.  

Once the board has been added, it can be modified afterwards, extra segments can be added and 
the corners can be mitred or made curved. 

For this tutorial, during the Schematic To PCB conversion process earlier we have specified the 
board outline as a square of 3000x3000 thou. If you require cutout shapes in your board, add these 
using the Add Board Shape option. DesignSpark understands that board outlines inside the main 
board outline will act as cutouts. 

Importing a new board outline using a DXF file 

Instead of drawing a board outline, you can also import a DXF file previously created in your 
mechanical CAD system, such as AutoCAD. 

If you wish to import a DXF file, use the Import option on the File menu. You are presented with a 
dialog to map shapes and text in the DXF file into your DesignSpark layers. You can also change the 
import Units to adjust the import scale. More information about this option is available in the Online 
Help. 
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Placing Components 
Placement can be an automatic or manually process. Automatic placement can be either during the 
conversion phase or by using the Auto Place Components> option from the Tools menu. Manual 
placement can be done at any point in the Design editor, even after using the automatic placement 
option. 

We’ve started the design with the board outline and are now ready to try manually placing the 
components. Currently, our design has been placed during use of the New Board Wizard option. We 
will un-place the design first. 

Drag a box around the components in the design to select them.  

 

Now pick and drag them outside the board outline. Had you chosen the option Arrange Outside 
the Board, this would have stacked them neatly outside the board outline ready for manual 
placement. Once outside the board outline, release the mouse to place them. Click in free space to 
deselect the components. 

 

 To place components 

DesignSpark uses standard Microsoft Windows methodology throughout, moving or placing 
components is a simple case of picking and dragging the selected component. At any time during 
move, the drag may be cancelled by pressing the <Esc> key, or once released by using Undo 
<Ctrl-Z>. 

Using the pick and drag method, place all the components to look like the picture below.  

We suggest you place CONN1, U1, U2 and U3 first and place the other components around these. 
Placement on this design isn’t critical but improve it if you feel you want to. 

When placing U3 we have rotated it to get it closer to the connector CONN1. We will also place the 
decoupling capacitors close to this device as they are pretty sensitive and are there to reduce noise 
of the voltage regulator. 

Place capacitors C6, C7, C8 and C9 as close as you can to U3. To follow our example exactly as the 
picture below, you will need to rotate some of the components. 



40   PCB Design Editor 

 

Once you have these components placed, we will fix them. On a real design, let’s assume you might 
have some critical components which are placed specifically. You would then want to fix these so 
they cannot be moved accidentally. 

 To fix components 

To fix components, select the component and use Properties from the shortcut menu. 

On the Component page, select the Fixed check box and press OK. This will fix the component. 

 

The Fix Item option is also available on the shortcut menu for a selected component. 

 To rotate components 

During Place or after placing components, use the shortcut key <R> to Rotate them and <F> to Flip 
(mirror) surface mount components to the other side of the board. These options (and more) are 
available on the shortcut menu during Place by clicking the right mouse button. 
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 To flip (mirror) components to the other side of the board 

For our design, no mirroring (Flip) will be required. The placement and overall connection lengths 
could be improved by rotating some of the components. If you feel you would like the practice 
placing components, select a component and click <R> to rotate it. Component names can be 
rotated back to be a readable direction separately using the same pick and rotate method. 

Once fully placed, the design should be routed. 

 To use the autoplace option 

We’ve placed some of the critical components and fixed them in-place. Now we will place the 
remaining components using the Autoplace option. 

From the Tools menu, select Auto Place Components>, choose All Components. 

 

From the selection available, we want to View Component Placement so check the box. Also 
check the Don’t Place Fixed Components box, we want the fixed components to remain in-place. 

Set the Minimum Space Allowed Between Components and Placement Grid values to 100 
thou each. You can play about with these values if you like. Place the remaining components and 
use Undo if you wish to try a different placement pattern. Perhaps changing the Grid to 50 thou. 

Press OK to make the placement. The remaining components are placed around the fixed ones in 
the space available. 

 

 Save the design 

Save the design using the Save option from the File menu or click the Save icon on the toolbar. 

The PCB design has already been named when you translated from Schematic to PCB, we named it 
Tutorial.pcb. We named it this so it matches the name of the Schematic. This will become more 
important later on when you run the integrity checks before plotting. 
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Routing the Design 
The design can be routed manually or automatically. This is the process of converting the electrical 
point-to-point connections into physical copper ‘tracks’. 

Initially we will route the design automatically to see what the result looks like and to try this option. 
We will then Unroute it back to the ‘rats nest’ and use the manual routing tools to route it. 

Automatic Routing 
The Autoroute option is used to convert your nets into electrical tracks as you can with manual 
routing. However, on dense designs it can save you many hours or days of work. The autorouter can 
take an unrouted design and route it within minutes quite often.  

You can use the autorouter in many modes; on All Nets in the design, on Browsed Nets, 
Browsed Net Classes, on selected nets and on components. 

 To use the autorouter 

From the Tools menu under Auto Route Nets>, select All Nets.  

Leave the default settings as they are: 

 

Simply click the Route button at the bottom of 
the dialog to start the router. This small design 
will easily route 100%.  

 

The results are quickly displayed: 

 

Click OK to close the report dialog and view the 
routes. 

 

The routed design might look something like this below. This will vary depending on how you placed 
the design. 

 

 Save the design 

Click the Save icon on the toolbar or Save from the File menu. 
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Unrouting the design 
You may sometimes have a requirement to unroute all or part of the design. Unrouting is the 
process of removing tracks leaving only the connections remaining. 

The Unroute Nets> option is available on the Tools menu, with three options available to control 
the amount of unrouting to perform. 

 Unroute the design 

For our exercise, use the Unroute Nets> All Nets option to unroute the whole design removing all 
the tracks already done. Don’t forget, once unrouted, you can always restore the routes using Undo 
<Ctrl-Z>. 

 

Manual Routing 
DesignSpark has a set of powerful manual routing tools to aid this process. These tools allow you to 
swap layers, automatically add vias on layer swaps and edit track thickness. 

For our example design, we will now add the routes in by hand (manually). 

 To start routing tracks manually 

To start adding tracks, double-click on a connection, this is the quickest method to start routing, 
other methods are available. 

 

 

 

If you followed our design placement loosely, 
double-click the connection between C10 pin 2 and 
R6 pin 1. 

 

 

Move the cursor to the down and right slightly. 
You’ll see the track starting to take shape and a 
connection between the end of the track and the 
‘target’ pad (R6.1). In this mode, the track is 
placed orthogonally at 90 degrees with two 
floating segments. 

 

 

 

Move the cursor down to draw the vertical track 
segment. The track is still being placed with 2 
segments and a 90 degree corner. 
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Click the mouse once, this places the first track 
segment (the straight track segment coming out 
of C10.2). This is temporarily ‘locked’ in place for 
this routing session. It can be moved or edited 
later on. 

 

 

Now we will add a track layer change. 

Press the ‘L’ key on the keyboard and the Track 
Layer dialog is displayed. During normal routing 
where a layer change from one side to the other is 
required, a simple ‘L’ followed by <Enter> is all 
that is required. The Enter button is the same as 
clicking OK on the dialog. In time you will be able 
to change layers without looking at the dialog. 

 

 

A via has been added automatically and the track 
layer is now on the Bottom side. This will be 
displayed on the Status bar at the bottom of the 
DesignSpark window. 

 

 

 

Move the cursor right and click again.  

This will either be the next corner or the next 
location for a via for a layer change. Notice the 
track has changed color to show it is on a different 
layer. 

 

 

 

 

Press ‘L’ and <Enter> again to change layers 
back to the Top layer. Another via is added 
automatically. 

 

 

 

Continue moving the cursor right towards the 
target pad R6.1. Notice how it is on the Top layer 
shown in Red. 

 

Once over the target pad, click once to finish the 
track editing for this connection. Note the track 
colour is now red again, showing it is on the top 
layer. 

After the track has been added, it can always be 
modified afterwards by picking and dragging the 
track or by double-clicking on the track to edit it. 

Move onto the next connection for editing. 

Summary of the basic modes of routing 

During track editing, the basic commands for use are:  

 Single-Click, once editing, this will insert a corner to change routing direction. 

 <L> followed by <Enter> will enable a layer change to the opposite side of the design. 
This can be used during editing, or afterwards on selection of a track. 
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 To change manual routing modes 

You would have been using the standard routing mode of Orthogonal routing (two ‘floating’ 
segments at 90 degrees to each other).  

 

 

 

 

 

during routing, this mode can be changed 
by accessing the routing mode. Select the 
Segment Mode> from the shortcut menu 
and choose the mode from the choice of 
five available. 

 

 

On our example design, the routing may 
now look like this using the Mitre mode. 

Picking in tight areas 
When attempting to select items within a dense area of the design or where multiple connections 
cross each other for example, it is not always easy to pick the item required at the first attempt. 
Under these circumstances DesignSpark has a system of picking that 'cycles' through items adjacent 
to it until you select the item required. Once selected, an action may be made on that item, 
Properties for example. 

The shortcut key used for the command Select Next is defined as <N> for Next. 

To try this, click on a pad that has a track attached to it, the pad (or track) is selected. Now click 
<N> and the track (or pad) will be selected. Depending on how close it is to other design items, the 
component outline and the whole component may also be selected at each click of <N> is made. 

Pouring Copper into Areas 
Copper Pour is used to flood areas of a PCB layout with copper, usually connected to a nominated 
signal through ‘thermal’ connections, typically Ground (0V) or +5V. This facility will then create 
voids around tracks, component pads, vias and other electrical obstacles.  

For this we have the Add Copper Pour Area and Pour Copper options. 

If a copper area is to be inserted without the need for voids around unconnected tracks, components 
or pads, the Add Copper option can be used. 

The principle of this facility is to insert a Copper Pour Area and ‘pour’ the copper into this area. 

 To create a Copper Pour Area 

From the Add menu, select Copper Pour Area> Rectangle Other Pour Area options are available 
for adding different shapes. We will add the pour area to the Top Copper layer. pour areas and 
poured copper can be added to any electrical layer. To change layers, select the pour area and click 
<L> followed by <Enter> as we did when editing tracks. 
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The shape can be created on the design and the pour area can be drawn protruding outside the 
board outline. DesignSpark will pour the copper using the Spacing rules and rules defined for the 
Pour area. 

Following the picture below of our example, draw in a basic rectangle pour area shape, this is shown 
in black in the top left hand side of the design: 

 

For this example you will see how easy it is to add a poured copper area. 

Right click on the pour area. 

From the shortcut menu select Pour Copper. 

 

A dialog is displayed from where you can select parameters for the poured area, such as the net 
name association and thermal connections etc. 
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For this exercise, leave the Net Name blank and simply click OK. 

Notice that the poured copper has obeyed the Spacing rules of all defined items to copper including 
Board to Shape rules. 

 

 To remove poured copper from a copper pour area 

 

To remove a poured copper area (including any thermal spokes), 
simply select the area outline and select Clear Copper from the 
shortcut menu. This removes the copper but not the Copper Pour 
area. 

When using poured copper remember you shouldn’t use Delete 
but should always use Clear Copper. Copper Pour Areas can be 
modified at any time and the area re-poured using the option 
from the shortcut menu. If you wish to completely remove the 
copper and area, you must use Clear Copper first and then delete 
the area afterwards using the Delete key.  

 

 To make the copper Pour Area intelligent 

There are more facets to the poured copper than we have discussed above. The poured copper can 
also have a net name associated with it so that when poured, pads are connected via thermal 
spokes to the copper itself. To do this, select the pour area and from the shortcut menu select Add 
To Net. Select the net name required from the list and then re-pour the copper. Try it again using 
0V as the net name and click OK. 

   

Using the Spoke Style check box settings for Spoke Style, Spoke Width and Isolation Gap, the 
style of how the copper is connected to pads can be defined.  

In Spoke Style: type Spoke 10. Type 10 for Spoke Width: and 10 for the Isolation Gap:. Press 
OK. When requested, add the new style, Spoke 10 to the Technology. 

Copper Pour Areas will not appear on your manufactured boards, they provide the system with an 
intelligent area into which the copper can be poured. 
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Checking the Design Integrity 
Various checks are available in both the Schematic and PCB editors on the Tools menu. This is used 
to compare and verify designs and make changes in the PCB so that they are both in-sync with each 
other at all times. 

 To check the designs  

You can use the Schematics/PCB Check option on the Tools menu at any time. By default, the 
file used for the comparison will be the same name as that used for the Schematic (or PCB design if 
running from the Schematic editor). 

When run, if there are no differences, the following dialog is displayed: 

 

If differences are found, Notepad will be run to view a detailed report. The report will give you a list 
of changes that would have to be made to the PCB in order to make it match the schematic (the 
schematic always being the ‘master’). You can then perform these changes automatically by 
selecting the Yes button on the dialog. 

 

Run this option on our tutorial design, there should be no differences. If there are, click the Yes 
button and make the changes. 

 To bring Schematic changes into the PCB  

If at any time you want to ‘push’ Schematic changes into the PCB design, run the Forward Design 
Changes option from the Tools menu. This will run a comparison of the Schematic against the PCB 
and will only make the changes required to the PCB. It will report all the changes made. 

 

 To back annotate name changes to the Schematic  

Back annotation changes can be made in the PCB, and these can be passed back to the schematic 
also using the Back Annotation option from the Tools menu. When run, it will report and allow 
you to perform any back annotation changes to the Schematic that are ‘pending’. 
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Design Rules Checking 
Before sending your design for manufacture, you must run the Design Rules Check option. This 
dialog contains check boxes that enable various checks to be made. The checks are made against 
the Spacing rules defined. This is also used to check various manufacturing rules have been 
obeyed.  

When errors are found Error Marker letters are added to the design on the appropriate layer to help 
you find and correct the actual error. 

 To run a Design Rules Check 

Select the Design Rule Check option from the toolbar. 

 
 

  

A dialog is displayed that allows you to control which items are 
included in the check. Click Check to run the DRC. 

 To locate DRC error markers 

After running a design rules check, you can find the error markers in the design using the Goto 
browser. This is available on the Interaction bar by pressing the <F9> key. 

When the Goto browser is displayed, from the list of available Goto options, drop the list down and 
select Error. 

 

This list is used to view all the design error 
makers as a sorted list. It is displayed in an 
'active' browser, click to select an error, you 
can locate the error maker in the design. If 
the error marker is off the screen, it will be 
brought into the centre of the display so it can 
be seen. 

 

If at any time you right click on the Errors 
bar, you will see a shortcut menu displayed. 
From this you can choose various locate 
options to aid the finding of error markers in 
the design. 

You can choose to list errors by Type or by 
Layer also on this menu. 
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Viewing Power Plane Layers 
If you have included powerplane layers in your design on the inner layers, before you send off the 
PCB design for manufacture, it is worth running a visual check of the thermal connections. This 
visual check will validate any potentially missing thermal spokes where a pad to copper connection 
has not been made. Where a pad to copper cannot be made because of design restrictions, the 
thermal spoke will not be added. Your check will identify these missing connections. 

To do this, select the Powerplane > option from the View menu. Select Show… 

 

From the list of powerplane layers, select the layer required.  

 

If we select the +15V layer for our example, the plane will look like this: 

 

Once finished, select the View menu and use Powerplane > Hide to switch it off. 
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Reports, Part Lists and Net Lists 
DesignSpark can generate reports where all vital aspects of the design can be output in detail. The 
reports also include a set of ‘standard’ reports like Component lists and net lists.  

These reports are all available on the Output menu. 

In Schematic editor: 

 
 

In PCB design editor: 

 
 

The Reports dialog is displayed. From here you can access standard reports under Built-in 
Reports and the custom report builder option under User Reports. 

 

During your trial of the options, run each report to see what they can produce for you. Each report 
will be displayed using Notepad, close the report once viewed. 

 To create custom reports 

The bottom half of the Reports dialog is dedicated to the creation of custom reports. 

 

Use the New and edit buttons to access the Report Builder option. 
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From within this dialog, you can add commands to construct your own report and format it in the 
way you require. Some basic reports and outputs have been created as examples for you to see. 
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Chapter 5. Manufacturing the PCB 

Plots and NC Drilling - Overview 
DesignSpark provides you with a mechanism for plotting your designs in standard manufacturing 
formats, such as Gerber and Excellon NC drill. You can also print the design to Windows printers and 
PDF for documentation purposes or for checking. 

The Plotting Dialog 
The Manufacturing Plots plotting dialog is accessed from the Output menu. 

 

The dialog is split into three main areas: 

Plots 

From here, choose the plots and the plot selection for output and plot name. 

 

Output 

From here, choose the output type, layer choice, plot contents (Settings) and plot scale. 
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Auto-plot generation 

From here, choose to Auto-generate plots, add new plots to the set, delete plots and align plot 
contents with each other (position, scale etc.). 

 

Using the dialog 

For each plot selected in the Plots: list (Top Silk for example), the name is displayed above the 
Output pane. The contents of the Outputs pane, including the Output, Layers, Settings and 
Position tabs, are used to create the contents of the plot. 

So in our example below, the Top Silk plot will be output to Gerber in an Artwork style and will be 
output to a file. 

 

Still for the Top Silk plot, let’s look at each of the four tabs:  

 

On Layers, choose the layer or layers (you can 
combine layers if you wish). 

You can see that for our Top Silk plot, the Top Silk 
layer has been selected. 

 

 

On the Settings page, the parameters 
here define the contents of each plot. 
It defines more specific items for 
inclusion and how they are plotted. 

 

 

The Position tab allows you to define the 
scale and position of the plot. 

A (non-editable) check box at the bottom 
of the dialog displays whether the plot will 
fit or not. If it doesn’t fit, the box changes 
to a red cross. 
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The Plotting Process 
To generate plots for manufacturing, you need to plot Gerber plots for the electrical and non-
electrical layers and Excellon NC drill files for drilling the board. 

On opening the Manufacturing Plots dialog, you will need to first set up each plot required to 
create you an overall set of plots. For a new design, the plots will be automatically created for you 
based on the layers and layer classes in the design and intelligence built into the product. 

Once a set of plots has been created, the next time you enter this dialog for the design, the settings 
will be remembered. 

Creating plots 

Once all the parameters have been set for each plot, you can output them. 

Use the Run button to create plots of all the plots in the Plots: list, the ones that have a ‘tick’ next 
to them. 

 

Plots with a tick are output: 

 

For each plot, the Output To: selection will define where the output goes to. 

 

 

If you select the Options button on this page, your can direct the plot to a specific folder under 
Where Plot Files Are Written: By default, the files are written to the same directory as the design 
file. Another option is to specify the Plots sub- directory under the design directory. 
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Previewing the plots 

If you wish to view the plot to see it’s position, size, contents etc. check the Plot Preview check 
box. A Preview pane on the right side of the plots dialog is displayed. 

 

Within the Preview box are three main boxes: 

Red box – this is the plot ‘bed’ or paper size. This will be the maximum size (minus any 
hardware edges) that the plot can occupy when fitted to the page. 

Blue box – These are the design extents. If for example, you have a drawing border with a 
board outline inside it, you will see the box box is the same sieze as the drawing border. 

Green box – This is the board outline. 

 Contents – the contents of the plot will be displayed inside the blue or green boxes. These 
are approximate contents to give you a quick preview of the final contents. For example, it 
will clearly show you a silkscreen outlines plot rather than a plot being a power plane. 

 

Plot ‘bed’ box 

 

Design extents box 

 

Board outline box 

 

Plot contents 

 


